An invoice that previously synced successfully to QuickBooks Online fails to sync and displays an error indicating that the related project record cannot be found.
Cause
This occurs when the project mapping between BQE CORE and QuickBooks Online becomes invalid. In CORE, the mapping might display “record not found in QuickBooks”, which typically means the project or related record was deleted, modified, or became corrupted in QuickBooks Online, or the mapping was disrupted during a prior sync.
Resolution
Un-map the affected project that displays, record not found in QuickBooks, then remap it to the correct active record in QuickBooks Online and sync the project again. After the project mapping is restored, resend the invoice to complete the sync successfully.